Redis 配置教程:
在开启redis缓存前,首先在宝塔软件中心找到Redis安装该软件;
避免爆内存导致的redis崩溃暂停服务的必要优化操作
1.根据服务器的实际空闲内存进行分配 为redis预留的内存容量 应在实际空闲内存以内 空闲内存在1GB以上则应该设置1024MB;
2.在 Redis 配置文件中将 # maxmemory-policy noeviction 改为 maxmemory-policy allkeys-lru (去掉前面的#号否则不生效);
解释: noeviction:内存触达上限,拒绝所有写请求(业务报错、暂停写入),读还能走;如果系统整体内存不够,Linux 内核直接 OOM kill 掉 redis 进程 导致 Redis 崩了、停止。
解释: allkeys-lru:内存满时,自动淘汰最久没访问的 key,持续释放内存,不会卡死、不会直接崩。
以上操作完毕后需要重启redis服务
然后在软件中心找到当前站点所使用的PHP版本打开设置页面进入安装扩展,选择安装Redis的扩展即可;
以上操作完后即可在网站后台开启redis缓存功能体验极致速度。
本文由网友投稿或聚码屋整理自网络,如转载请注明出处:https://www.ym3.net/2601.html;
本站发布的内容若侵犯到您的权益,请邮件联系 cnzz8#outlook.com 删除,我们将及时处理!
本站大部分下载资源收集于网络,不保证其完整性以及安全性,请下载后自行测试。
本站资源仅供学习和交流使用,版权归资源原作者所有,请在下载后24小时之内自觉删除。
若作商业用途,请购买正版,由于未及时购买和付费发生的侵权行为,与本站无关。
还没有评论,快来说点什么吧~